Installation problems?

I setup a Linux VM to use for the course and installed 'IDLE (using Python 2.7)'
I think that should do it!

1 Like

Thanks! I installed IDLE as well. :smile:

I used Python 2.7.x during the previous run of the Mechanical MOOC, and it caused no problems at all with any of the work, including the three projects during the final weeks of the course. Don’t use Python 3.x, because, although you can make slight adjustments to your code in the earlier portions of the MMOOC to get it to execute properly in Python 3.x, it would take immense amounts of work to adapt the culminating Tetris project to version 3. Tetris uses a graphics module to display a game board, and you would have to redesign that module, as well as the starter Tetris code, in order to adapt them to Python version 3.x. Save that effort for a future post-doctoral version of the MMOOC. :wink:

I downloaded 2.7.7 to get prepared for this MOOC. But I don’t understand how to install IDLE. In my Python27 folder I see python.exe and pythonw.exe plus other stuff, but nothing that says IDLE. I am using Windows 8.1 64-bit.

Update I: I just downloaded 2.7.9. I now see in Lib/idlelib. When I try to open it opens for a second and then immediately closes.

Update II: I looked for other online help. I tried this:

  1. At the cmd prompt I entered: cd c:\python27
  2. After python starts I entered:
    import idlelib.idle
    And got: IDLE can’t import Tkinter. Your python may not be configured for Tk.

This is the document I could find to help you. The problem you are having is there is a library missing, that IDLE is using. If you are able to install this library, you will be good to go.

Let us know how it goes.

If anyone else already solved this issue, could you please help @JMBoston?


Attempting to use in order to run IDLE is probably opening, and then instantly closing, a command window.

Are you able to get to Programs, then Python, and then to IDLE, via the Windows start button? That may work. I have done that on Windows 7, but have not tried it on Windows 8. If it works, you can then send an icon for IDLE to the desktop, if you do not have that icon there yet.

I don’t see any document. If you attached something to your post I don’t see it. Also, I downloaded Python from the website recommended in the MIT starter guidelines. Why would I have failed to download a critical library file?

Can you be more specific? For one thing, I don’t have a “Start button,” or none that I see in Windows 8.1

Is there a button or something of that ilk in the lower left corner of the desktop that you can click on to get to a menu, that includes a “Programs” item?

I am sorry I have left out the link, I am editing the post now.

and the link to the document is here

No Start button in Windows 8.1. I think that was in Windows 7 and earlier.
Anyway, I used the Start window in 8.1. There I found the Python GUI (Idle). I pinned it to my task bar but IDLE still doesn’t open. So it seems I have IDLE but there’s still a problem. Maybe a pathway problem?

Yeah, I think we have to get help from someone among us who has access to a Windows 8 system.

I went to the website you recommended, which in turn recommended [][1] for getting the tkinter files.

After downloading a Community Edition of ActivePython I followed these instructions:

This should give you the Python command prompt. From the prompt, enter these two commands:

import tkinter

However, when I run import tkinter I get “ImportError: No module named tkinter”. This is getting exasperating.

Update: This is getting worse. I want to uninstall Python and start all over. When I try to uninstall Python 2.7.9 downloaded from the website this MOOC recommended (via the MIT starter guidelines) I get this pop-up message: “There is a problem with this Windows Installer Package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.” When I click OK the uninstall process shuts down. So now I’m trapped with a faulty version of Python on my computer.

Update II: Finally managed to uninstall (process is too long to explain). I’m starting all over again with Python installation and will report back.

Finally got IDLE to work. I had to re-install an ActivePython Community Edition (which I guess, though don’t know for sure, contains the tkinter file I was previously missing) from this website.

Anyway, the download from the website recommended by this MOOC (again, via MIT) did not work and was uninstalled. I don’t know if my problem was specific was to Windows 8.1, but if it was, this is one doable fix.

I have a problem with downloading. I tried adjusting my security settings but nothing seems to work. I don’t know if you can help with this. I am using Windows Vista Home and Internet Explorer.

When I go to the page listed in the email and click on the download link a ribbon appears at the bottom of the page but only with the “Save” option. The same thing happened when I tried to download Firefox. When I click save I get a message in that ribbon like:

“python-2_7_8_amd64_msi (2) couldn’t be downloaded”

Hi Chiboli! Try this link: (Python 2.7.9.)
Scroll down to the very bottom, there are two options for Windows.

Hope it helps!


Thanks, but the same thing happened.
Actually its not a problem with all downloads as I seem to be able to download documents. It must have something to do with programs so I even tried disabling my firewall. But something has gone wrong and it doesn’t look like there is an obvious solution to me.

My guess: Corrupt user account (probably not) or the internet settings don’t allow the download.
Open internet options or internet properties can’t remember, open security tab.
Scroll down to Downloads and click radio button to enable .
Restart browser for good measure.

Hope this will do it.

Thanks again for your suggestions, but like I said this problem does not have any apparent relation to any of the menu option anywhere on my computer. I even tried listing the Python site as a “trusted site.” I guess I will have to conclude that somehow a virus is responsible. I have been running without any protection for a few years now so it was inevitable.

I managed to solve the problem by downloading Google Chrome and then the Python programs. Must have had something to do with Internet Explorer, then.

1 Like